Custom theme not displaying properly in extended project

We have developed a custom theme for our base project which extends Halo. When ever we create a new project which extends our base project most of the theme comes across correctly but our tab captions keep getting the “framed” style applied even though they should not and don’t in the base project.

I have compared the css file that our theme generates in the base project and in the extended project and they are identical however upon running the application you can clearly see the differences.

The extended project does not have its own theme, it is using the theme from our base project so I do not understand why the projects appear different than the base one.

Has anyone else seen this behavior or know what might be causing it?

Any guidance is greatly appreciated. Thank you,
Corey Amoruso

Hello @Corey.Amoruso

I’m sorry for waiting.

Could you share theme-related sources to check what is wrong?



I have attached a zip file containing our themes resources. Since my last post we have run into another possibly related issue with the extended project theme issue, one that may be easier to troubleshoot.

We have recently updated the status-frame.scss file under the Varasset/app directory of our theme resources to fix an issue with an element not sliding to the side enough. In this file there is an element defined as “.v-verticallayout-wfTaskBoxClose”, we have recently changed the transform property from “translateX(200%)” to
translateX(800%)". After updating this file we pushed the changes to our local Maven Repository and I pulled the changes down to my project which extends the Varasset base project.

In Intelli-J, under the External Libraries of my project which extends the base Varasset project, I can see the updated value (800%) in the status-frame.scss file. However upon building the project the styles.css file that gets generated in the VAADIN/themes/varasset directory contains the old value of 200%.

It appears that during compilation of the themes the old version of the file is getting used somehow. I have made sure to clear my gradle cache and delete the External Libraries containing these files in order to pull fresh ones from Maven but still have had no luck.

I feel like this issue might have been the cause of the behavior I was seeing in my original post. It appears as though there is some issue with the generation of the style.scss when done from a project which extends our base project which defines the theme. (28.8 KB)

Please check that you don’t have locally installed old version of project in <home_dir>/.m2/repository/ directory.

Could you clarify the following moment: the base project is used as application component in the project where new styles are not applied?

Have you tried to fully rebuild project with cleaning build dirs?



I cleared out the local repository in the .m2 directory and did a rebuild after performing a clean but am seeing the same result.

That statement just meant that my project which is extending my base project is using the base project’s theme and that we are not seeing all updates from the base project’s theme reflected in the project which extends the base project.