CubaApplicationServlet - Too long request processing


How do i troubleshoot the above warning in the log file? The warnings occurred when opening the edit screen of a child entity in one-to-many composition. The screen opening is slow when there are many associated children in the composition (e.g. 100 to 200 rows). I would much appreciate some help to resolve the issue with the response time.

Thanks in advance.

Hi David,

I would recommend finding out what SQL is executed when you open the screen. Set DEBUG level to the eclipselink.sql logger at see the log file. Loading of 200 rows should not be a problem if you have properly defined indexes for related entities. Try to execute the generated SQL manually in a database management tool and check the execution plan. If some indexes are missing, you can add them to update scripts and 30.create-db.sql.

How can I

in Idea ??


You have two options:

  1. Setting up Logging in Tomcat
  2. Setup logging runtime
    2.1. Open the Server Log window (Administration > Server Log)
    2.2. Switch to the Options tab
    2.3. Click the Control button
    In the opened dialog you can edit existing and add new loggers


1 Like

Hi Gleb,

Can please be a little bit specific?
I changed eclipselink.sql from INFO to DEBUG (APPLY - LOGGER SET) but how can I see it (log output?
I have to start my application in Debug mode or what? eclipselink.sql doesn’t appear in view - log file.

After you apply new settings, you’ll be able to see changes in app.log and catalina.out files. You can view their content in the Server Log window (first tab). Pay attention that option 2 (Setup logging at runtime) works until the next app restart. Every time you restart the app, logging settings are loaded from logback.xml

Now it works. My problem is that take too long time to start the application (see attach).toolong.txt (58.5 KB)
Is it normal?