CUBA Studio 2019.3 - Data Model Entity Designer issue

Hello guys,

i’ve recently switch from Cuba 6.9 Studio (the seperate Sutdio running in the Browser) to Cuba Studio 2019.3.

Sadly i am experiencing issues when using the Data Model Entity Designer for one of my Entites. This exact Entity opens fine in Cuba Studio 6.9.

Following issue:
I have an ENUM Field mVorlageTyp which is not correctly say “interpreted” in Cuba Studio 2019.3. Here is how it looks in 6.9:


Now when opening this entity in Cuba Studio 2019.3, it shows up as a String field. Also every field i view in 2019.3 for this entity comes up as “Read-only” Field, which isn’t correct:


Now the really troublesome part, when i switch over to the Java Editor, it actually added a getter for the mVorlageTyp Field:


The correct getter and setter for the ENUM is already present in the code:



so i need to delete the wrong getter manually. i tried removeing the the mVorlageTyp from the Instance Name, also i tried switiching the ENUM field to another field position. Nothing changed the behavior. I have many other Entities using ENUMs all opening fine. The issue appears only with this one.

Does someone have an idea how to solve this ?

Thanks and best regards

We have reproduced this bug. Looks like it happens when the attribute name starts with one lowercase letter. It will be fixed in one of next Studio bugfix releases.

Note that recent versions of IntelliJ-based Studio don’t fully support projects based on CUBA 6.9. Supported versions start from 6.10.

1 Like

Thanks for the feedback.

i wasn’t able to import from 6.9 directly to the new 2019.3 Studio (IntelliJ-based Studio) it would throw many errors and not recognize my project as a CUBA Application. I used the Cuba Studio SE for version 6.10, changed my current project version from 6.9 to 6.10.
after that the import to IntelliJ worked flawless. Just so you know, i am working on 6.10 Version, since for 6.9, i wasn’t able to import it to IntelliJ.