cuba_LoginService is not registered in LocalServiceDirectory

I want to deploy an application on a Centos server.

Tomcat server is 8.0.45
Java version is 1.8.0_45

Tomcat is behind a Apache server, server by AJP protocol.

Everything looks ok in the log file, until I want to log in. Then I get this error.

2017-08-18 13:52:12.764 ERROR [ajp-nio-8903-exec-5] com.haulmont.cuba.web.AppUI - Unable to init ui
java.lang.IllegalArgumentException: Service app-core/cuba_LoginService is not registered in LocalServiceDirectory
        at com.haulmont.cuba.web.sys.remoting.LocalServiceProxy$LocalServiceInvocationHandler.invoke(
        at com.sun.proxy.$Proxy195.getSession(Unknown Source)
        at com.haulmont.cuba.web.DefaultConnection.doLoginAnonymous(
        at com.haulmont.cuba.web.DefaultConnection.loginAnonymous(
        at com.haulmont.cuba.web.AppUI.setupUI(
        at com.haulmont.cuba.web.AppUI.init(
        at com.vaadin.ui.UI.doInit(

Any ideas?


Usually it means that middleware server has not started. Check the beginning of the app.log, there should be the root error.

I solved it.

I had changed the default modules prefix in the project properties from ‘app’ to ‘klint’. Therefore my middleware path was klint-core/… instead of app-core.

Now I changed back too the default prefix app, make a new build and everything is working.

Did I do anything wrong by changing the moduls prefix?

How did you change it? Does it work with a custom prefix on your PC?

I changed it the Project Properties / Advanced screen in Cuba Studio 6.6.2.
Yes, it worked with the custom prefix on my PC without any problems.

Do you use any additional settings in production environment? How did you deploy your application? SingleWAR or copied exploded tomcat instance ?

Hello, i have the same problem, i deploy using SIngleWAR


Please open a separate topic and attach your log files. It is a very generic problem that might hiding actual problem on server start, so we cannot help you without additional details.