[CUBA 7] Hot-Deploy not working

Sure thing!

These days, I experienced a hot-deploy-less development flow and it is excruciating :laughing:

You said, that after the error has occurred, hot deploy completely finishes. We found a problem with CUBA 7 @UiController controllers, but the hot deploy of legacy screens should work as usual. Could you say, is hot deploy works on legacy screens after the exception?

The project I’m working on has all the screens migrated to the new API. The main window though, from what I know, uses the legacy API and the hot deploy used to work for that screen.

To summarize, the hot deploy doesn’t work for new CUBA 7 screens and works for the legacy API screens. Am I right?

No, tested it now and after the exception is thrown the App throws the same exception for all the actions I do after it is thrown.

So, bottom line, the hot-deploy does not work under any circumstances.

Hi @bujoralexandru1996

Can you please check our nightly builds 12.0.NIGHTLYxxx and test if this version works for you?

You can follow this instruction:

or just download .zip file from plugins repository:

(Haulmont_nightly list, then choose “Install from disk…” in IDEA).

To check whether our not yet publicly released bugfixes resolve your problem.

1 Like

Hello @AlexBudarov

Tried it just now, still not working, still throwing.

Could you share your project?

Hello Alex,

I faced hot deployment problem and this nightly build has fixed my issue.


@shustanov, the project I am working at is a closed-source enterprise project so sharing it is not possible, unfortunately. I will investigate if it is indeed working and I shall come with an answer by end of day.

@prashanth thank you for your input. Will try some more to see if it is indeed fixed.

LE: After the App start-up, I get this message in logs and it raised me some questions.

INFO: Server startup in 29336 ms
16:47:22.055 INFO  c.h.cuba.gui.config.WindowConfig        - WindowConfig initialized in 145 ms
16:47:23.688 WARN  c.v.s.communication.ServerRpcHandler    - 
The widgetset in use does not seem to be built for the Vaadin
version in use. This might cause strange problems - a
recompile/deploy is strongly recommended.
 Vaadin version: 8.8.5-1-cuba
 Widgetset version: 8.6.4-17-cuba

Yes! It works, but I needed to create web-toolkit module for it to work… Have no idea why. Anyway, now it does work.

LE: It started not working after a server restart… Same error is thrown in logs.
My final opinion after today is that hot-deploy still does NOT work as expected.

Could you try execute dropTomcat gradle task?

1 Like

have encountered the same problem.

Hi! Could you describe what exactly problem you have encountered, and attach idea and your application logs?

Executed dropTomcat, still not working.

In my case, invalidate idea caches helped with issue. Might be different problem tho’.

1 Like

Yes! It did work today, when I tried it. It’s the only consistent solution that I heard up until now. Thanks, @expresado !

It still does not work.
On mac os, at least.
Am I the only one struggling a lot with this messy major update?
Yes, i’m talking about CUBA 7.


It does not work on latest release of studio, but it works on nightly builds (but nighly builds are slow; my studio freezes from second to second). It’s just a bad development experience…

1 Like

I’m on nightly builds too.
Followed your discussion and tried everything.