[CUBA 7] Hot-Deploy not working

Executed dropTomcat, still not working.

In my case, invalidate idea caches helped with issue. Might be different problem tho’.

1 Like

Yes! It did work today, when I tried it. It’s the only consistent solution that I heard up until now. Thanks, @expresado !

It still does not work.
On mac os, at least.
Am I the only one struggling a lot with this messy major update?
Yes, i’m talking about CUBA 7.


It does not work on latest release of studio, but it works on nightly builds (but nighly builds are slow; my studio freezes from second to second). It’s just a bad development experience…

1 Like

I’m on nightly builds too.
Followed your discussion and tried everything.

Hi guys,
I have been experiencing the same problem even after upgrading the IDE to 11.1-183 .
However, i did notice the messages on the console while starting the application usually
console output(not catalina.out) prints
Starting the server....
Server started at http://<address>:<port>/app
In my case the second line was not present and so i tried creating a new project which surprisingly ran succesfully and hot deployement was working fine on it.
I am not sure if it is related to build.gradle file or something different is affecting the system.
Without hot deployment productivity has just went down.
Please help.


Things are back to normal.
In order to resolve this problem i have deleted deploy/tomcat directory then invalidated cache from the file menu as mentioned by @expresado then after a restart things came back to normal.

I am still not sure the specific reason behind it, but it seems previously deployed tomcat instance was causing this issue.

Hi! Could you attach your Studio and running application logs?


Could you please be a bit more constructive? You haven’t sent ANY logs, and DID NOT HELP ANYHOW AT ALL! We all can type caps letters and this will not help. What will help is the way to reproduce the problem.


We made a Skype call with one of your team members today and they couldn’t help either on mac os. Please understand my frustration - in CUBA environment with vaadin ui beeing server side rendered hot deploy becomes bread and butter, not something nice to have.

You can develop without it, but 3 times slower.

Thank you for your time,

LE: worked on mac os too on a sample project. so it’s something fishy with ours in the end. will keep you posted.

Hi everyone.

CUBA team understands that hot deploy is an important feature to speed up UI development.

What everyone needs to realize is that Hot Deploy is a very sophisticated feature inside. It is based on: class loading, resolving class dependencies, compiling Java at runtime, listening and merging for file changing events.
Therefore it is essential for CUBA team to get as much details as possible in order to solve possible problems with custom projects’ configurations. We would not be able to help you if you won’t provide us with as much details as possible about your project, environment, attached libraries.

Please don’t post any more additional problems happened to other users to this topic, better create a separate topic per problem, so we can keep things in order.

If you meet consistently reproducing problem with Hot Deploy feature, please create a separate topic with the following details:

  • Check if it works fine in an empty project in the same environment to clearly understand if it is specific project related issue or not
  • Java version
  • CUBA platform version
  • Studio version (plugin or Studio bundle)
  • Build scripts of your project: build.gradle, extra.gradle - so we can understand what libraries are included, possible build script customizations.
  • What file did you modify? Screen controller, spring bean, views.xml etc
  • What exactly happened? Exception in server log, freezing, updated source code not caught by running server etc. If there is exception in log - please attach it.
  • IDEA log file idea.log. It can be locating from Main Menu: Help -> Show Log in File Manager.

Please additionally note that Hot Deploy currently does not support source code annotation processing or any other way of preprocessing sources or bytecode.

Thank you for your cooperation.


I imagine there are quite a few people who can’t post projects on a public forum.

Maybe you should set up a private space where folk can post commercial code.

1 Like

I suppose that build.gradle file is not that much of a commercial secret.
Of course one should remove all private resource addresses, passwords and obfuscate company and project name.

Hi all!
We made some changes to the hot deploy mechanism. At 12.0.NIGHTLY144-183 these changes are available.

Can be downloaded from this page: https://plugins.jetbrains.com/plugin/7249-cuba/versions.

Or you can use the nightly channel in IDEA - CUBA Studio Nightly Builds Available - CUBA.Platform

We will be grateful if you try this version and report problems encountered during hot deploy.
Also, if you are experiencing problems with hot deploy, enable the DEBUG level for application logs:

  1. Open Help ->Debug Log Settings
  2. Set - #com.haulmont.studio

And after some development time in IDEA, send the log file to us. (Help → Show Log in Explorer)

In a new Studio update 11.2 we have included Hot Deploy improvements mentioned above by Alexander.

So I advise everyone to update to 11.2. If there would be any problems on that version, please share with us, not forgetting detailed information as described above.