Create database menu is inactive

I am trying my first application of Bicycle workshop following the document at CUBA website. I’m at page 41 of the guide, added all info and now time to create the database. Unfortunately, the option of “Create Database” is inactive which is under the menu “Run”. Can anyone give me a clue why it may remain inactive and how can I run the database script to create the database? (pl see the image)


Hello, Mortoza.
Just stop the server (Run -> Stop application server) and Create database menu item will be enabled.

Thanks Gleb.
But It doesn’t stop the application server when I choose that option. Any clue?

As stopping the server from the menu option failed, I tried to shutdown it from tomcat directory but it also didnt work. please see the attached image.


The stacktrace says that “Tomcat may not be running”. In case of this, you will need to find other applications that use the same port (8080). See this thread in order to find the application. You can also check whether the Tomcat server is running by finding its window. Please see the attached image.
Let me know if the problem persists.


Thanks. You’re right, there was another instance of tomcat that was running that I didn’t notice and only detected when I tried localhost:8080. It’s working now after I have shutdown that instance of tomcat.