Com.haulmont.cuba.testsupport does not exist

when I try to use com.haulmont.cuba.testsupport.TestContainer class in new module in one of my projects, I am getting error
com.haulmont.cuba.testsupport does not exist
import com.haulmont.cuba.testsupport.TestContainer;

I have added bewlow jar dependencies, but still I’m getting same error.

My project is gradle base project. I have tried adding this depenncies in .classpath file also. But this issue not resolving.

Just to be specific :I am Trying to configure unit test classes in web module.

You cannot use cuba-core testing library for tests in the web module.

If you need to test business logic located in the core module - write tests in the core module.
Tests in web module can cover logic related to UI, but in this case UI will be isolated from the middleware, middleware services will be mocked.
The third alternative, if you want integration testing of the UI - is to write tests using Masquerade (Masquerade – CUBA Platform), that will perform integration testing of the whole application .

1 Like