Column Header Name

Hi all.
If I change my app name (simple changing module prefix in Cuba Project Properties) when I deploy war file, the column of the table without caption are shown with the sintax [entityName.columnName]. The problem is only for the released version… in my local version in debug/developper mode the name of the columns are right.
For example if I have an entity called TAB_A and in my screen I have something like:

<column id="id.valueMax" caption="Max"/>
<column id="client"/>

for the first column I see the right name “Max” while for the other field I see TAB_A.client

So, I think that there is something wrong when I change my app name. I want to call my app in the browser with an url like http://localhost:8080/MY_NAME and not the classic http://localhost:8080/app

When you change the module prefix, Configuration Directory also changes.
Messages are loaded first from the configuration directory, so check its contents on the production server, maybe you’ll get a clue.

The file and the directory are ok. Just a confirmation: to deploy the solution on the final server I copy the war files (MY_NAME.war and MY_NAME.war) from my build\distributions\war directory in “Program Files\Apache Software Foundation\Tomcat 9.0\webapps” directory. Is it ok? Or I have to copy other files too?

That’s correct.
But you may also want to configure memory settings, logging, etc. See WAR deployment to Tomcat Windows Service.