Cannot resolve symbol 'Point'

I’ve try to create a simple project with maps addon. Step-by-step:

  1. Create new CUBA project
  2. Add Maps addon
  3. Create new Entity with ‘name’ as String and ‘location’ as GeoPoint…
  4. Look into code… and voila:

import org.locationtech.jts.geom.Point; // is RED…

CUBA Platform version: 7.1.0 (also try 7.2.7, 7.2.8, 7.2.9…)
CUBA Studio plugin version: 14.3-202
IntelliJ version: IntelliJ IDEA 2020.2.3 (Ultimate Edition)

What I’m doing wrong?

It looks like your project hasn’t been fully imported, library dependencies were not downloaded and indexed properly.

Try to re-import project again, e.g. in main menu: CUBA -> Re-import Gradle Project.

If you see the same error with many projects, maybe you have problem with downloading libraries from repositories? Do you use custom artifact repositories?

Nope. Nothing custom. Just new Cuba project and adding Maps Add-on. With commercial license. Only one entity, minimum steps to repeat this issue. I can show by TeamViewer or etc. Tomorrow I will try with my second computer…

I found one: adding custom dependency to org.locationtech.jts package last version can helps.

Maps add-on brings JTS dependency transitively.
Execute in terminal:

./gradlew :app-global:dependencies

You should see along compile dependencies:

> Task :app-global:dependencies


compile - Dependencies for source set 'main' (deprecated, use 'implementation' instead).
+--- com.haulmont.cuba:cuba-global:7.2.9
|    +--- org.codehaus.groovy:groovy:2.5.8
|    +--- org.codehaus.groovy:groovy-templates:2.5.8
\--- com.haulmont.addon.maps:maps-global:1.3.0
     +--- org.locationtech.jts:jts-core:1.16.1
     \--- ...

Yes, you right. But it’s empty:
Снимок экрана 2020-10-17 в 06.53.41

Problem solved. Package reloaded. Thank you!