AppComponents entity and services not detected in IDE

Hi. I have followed your guide on using app components. And all work well, the entity, screens, all are good. And I can use it. But when I want to modify my service bean, the IDE gave me error. While if I build the war and run it, everything run just fine. So, why is the IDE doesn’t recognize that I already import new dependency for my project?


Could you attach a screen shot with the IDE error? What kind of Service modification are you doing?

Hmm… I think I make the question bit confusing. So here’s an example. I have an “accounts” app components. And I want to use that component in my “hotel” project.

Which means, I can use any entity in “accounts”, as one of field in my “hotel” entity right? And it’s okay. In studio, I can do that. And when I generate DB script, update database, run the application, and even input data, all are okay!

But when I go to IDE (latest IntelliJ 2016.3, using the latest CUBA plugin), even the entity at hotel project tells me that entity from “accounts” is not exists. Even the import statement shows me ClassNotFoundException. But from studio, everything still went well.

Then I make a service/listener in “hotel”, and I need to use method in service I’ve made in “accounts”. Once again, the IDE said service Interface from “accounts” project is not exists.

In IDE they showed error, but studio it works well. Still, it’s not comfortable because you lost the purpose of using an IDE. Any help on this?

Can you remove the IntelliJ project file from CUBA studio and recreate it? It may work.

Yeah. I just tried that. And it works.
So I need to remove IDEA Project Files, and re-create it. Now it works. Thanks!

Maybe this need to be put in the documentation? Or I think there should be a better way without need to re create the project files.