AppBeans.get() unable to get Service in Integration Test

I have a Service with simple query in it that I’d like to integrate into unit test. But I constantly get
org.springframework.beans.factory.NoSuchBeanDefinitionException: No bean named ‘xxxx’ available error. I tried to use AppBeans.get() method , no luck.
I have tried the methods in the existing topics in the forum, none of it worked so far.
All I want is to test if the service queried the correct result from database.

Version 6.6.4


public class SampleIntegrationTest {

....
    private StatiiServiceBean statusService ;

    @Before
    public void setUp() throws Exception {
....
        dataManager = AppBeans.get(DataManager.class);
        statusService = AppBeans.get(StatiiServiceBean.class);

    }

The Datamanager can be found and no error using it.
Thank you

Try to look up by service interface:

statusService = AppBeans.get(StatiiService.class);

Ok I will have a try.

No Luck. I tried the StatiiService interface and StatiiServiceBean. None of it worked. The same error exception was prompted. I must have missed it somewhere in the configuration.
I tried to AppBeans.get() on the service com.haulmont.cuba.core.app.TestingService , it works and has no problem at all. It just happened to be the services that I created via Studio.

So where in the project tree the interface and the bean are located? And what is the component-scan package defined in your spring.xml?