Activation failed

Hello there,

I have purchased a licence last week, today I want to activate it in the Cuba Studio.
However, when I submit the key I get an “Activation Error” with “Activation failed” as message.
I am currently running Cuba Studio 6.2.8, is this an issue (since v6.3.1 is out)?
Does Cuba do log these things, and if so, where can I find them on macOS?

1 Like

Sorry for the inconvenience. We’ve found a bug that prevents activation if you are behind a proxy. It will be fixed in Studio release 6.3.2.

1 Like

Hi Max,

You can activate any version of Studio regardless of which is the latest. Please make sure Studio can access the URL, because activation is online.

Please email us at if you still have problems with activation.

Thanks for the ultra quick reply!
Indeed it may be a proxy issue.
I have set the env JAVA_OPTS to -Dhttp.proxyPort=3000 -Dhttps.proxyPort=3000
(the same proxy can be used both for http and https).
Nonetheless, I get the same error message.

I was now able to switch to another network which doesn’t require a proxy. I am now able to register with the given key, so that’s fine.

Hello Konstantin,

im writing in this topic because we have the cuba version 6.4.1 and 6.4.2 (we try with both).
And with both we are unable to register the license key, we are using also a proxy in work computer and that could be the only reason because in home computer the registration is working.

Hi Nicolas,

I assume that all other functionality like creating and opening project (which requires online access to our repository) works fine. Am I right?

Yes your are right, thats why is rare. The problem is only the registration.
Anyway i tried the quick fix that you give me in the email.

“A quick solution is to copy C:\Users<your_user>.haulmont\studio\sif.dat file from your computer with activated Studio to the one which has the problem. Exit from the Studio server before doing this.”

And now is working and registered.

So thank you!