AccessDeniedException on update to Cuba Studio 6.4.2


I tried to update CUBA Studio from 6.4.1 to 6.4.2 and get the following error:

2017-03-23 10:18:57,077 ERROR [] Error while installing update: java.nio.file.AccessDeniedException: C:\Users\ME\AppData\Local\Temp\cuba-studio-4545990696515687564\studio-6.4.2\web -> C:\Users\ME\.haulmont\studio\update\6.4\02\web

Do I have to run CUBA Studio as admin in order to avoid this or is this an issue of a missing access rights mask on CUBA Studio installation?

Thanks in advance.

Hi Marcel,

You don’t need Admin rights as long as you have all rights to the C:\Users\ME folder (assuming it’s your home folder).

Also, if the in-place update doesn’t work for some reason, you can always download the latest installer from our website and upgrade your Studio using it as if it is a first time installation.

1 Like

Hello Konstantin,

this is a strange issue… my javaw.exe process runs as me (user “MK”) and I also have full access rights to the .haulmount folder. (also to my own home folder) The initial installation of CUBA Studio worked fine and there’s been no issues when the .haulmount folder was created initially.
Do you run the installation script with elevated or alternative privileges? MK is a windows domain user.

The folder C:\Users\ME\.haulmont\studio\update\6.4\02\ (to be seen in the error message above) does not exist after the update attempt. Is this due to a cleanup after update failures? If so: can you assure that the “02” folder will be created with the correct access rights mask?

I’ll choose the manual option you’ve recommended when there’re no other options left.

Best regards.

Hi Marcel,

Unfortunately, we cannot reproduce the problem yet. Could you send us the full stacktrace of the error if you get it again?

As for non-existing …studio\update\6.4\02</i> folder - yes, it is removed automatically if the update fails.

Hi Konstantin,

I regret, there’s no stacktract in the studio.log file. I only can see those lines:

2017-03-27 14:33:35,257 INFO  [] Downloading distribution
2017-03-27 14:33:48,236 INFO  [] Installing update
2017-03-27 14:33:52,938 ERROR [] Error while installing update: java.nio.file.AccessDeniedException: C:\Users\MK\AppData\Local\Temp\cuba-studio-2010918023343579336\studio-6.4.2\lib -> C:\Users\MK\.haulmont\studio\update\6.4\02\lib

It is reproducible as user MK and also as local system Administrator. The latter is quite annoying as the lifted privileges should be sufficient. Do you have any further ideas?

You are right, Studio unfortunately doesn’t write a full stack trace in this case.

We are going to release 6.4.3 in the next couple of days, and we’ll add full logging of this error there. So I’d suggest to update to this release by downloading the full installer, and later try updating in-place. If the problem persists, we’ll at least get a full stack trace.

Okay, that’s fine, I’ll give you feedback asap.