Latest MS Word (Office 365) causing error when used to create DOCX Report Template file

I am getting the following error when generating a DOCX Report :

  1. I use Word from Office 365 to generate a report Template file with extension *.docx
  2. Create a report with Output type “DOCX”
  3. Run the report
  4. Open the *.docx file created.
  5. The above error is displayed

If I use Wordpad to create the report Template file, it seems to work

Is this a bug ?

1 Like


It’s not clear what do you mean here:

Report template is generated by Reports, did you mean “to edit generated template”?

I tried to reproduce the issue. In case editing generated templates I had no problems with opening output file using OpenOffice or Word from Office 365.

In case creating template in Word from Office 365 and uploading it to report there is a problem with opening file using OpenOffice:
but I had no problems with opening output report file using Word from Office 365 again.

Which program do you use to open the output file?



I was creating the DOCX template manually using Word from Office 365 and then uploading the file into my Report.

Also if I allow Reports to generate the Word template and then use Word from Office to edit the template and re-upload, I then get the error as if the template becomes corrupted.

So the question is: Are we allowed to create DOCX templates manually then upload ?

1 Like


According to documentation user can create several templates for one report and load template file from file system.

It’s recommended to use and edit (if you need) generated template file from report because it has a specific file structure.


We’re seeing the same issue. It’s only started happening recently. In our app, the users can create templates in Word and add mail merge fields. This has worked fine for several years. What happens now is that when the template is put through yarg reporting, the output file no longer opens properly in desktop Office 365. MS-Word displays the following error. In this case the template file was created using Word and just has a single line of text and no mail merge fields

…some time later, having looked at the output file, adding
xmlns:w16sdtdh=“” to the word\styles.xml\w:styles section of the docx file fixes the issue in my test file

resolved in docx4j here


Thank you for reporting the problem. We have created the Github issue.

It will be fixed in the next platform release.


1 Like

I just upgraded to Platform version 7.2.14 and this bug is now fixed